设为首页收藏本站

Panabit Support Board!

 找回密码
 注册

QQ登录

只需一步,快速开始

    初冬送温暖,派网派福利! ---小区版活动火热进行中!了解详情请点击这里。
搜索
热搜: 活动 交友 discuz
查看: 11248|回复: 5

iXCache镜像模式部署

[复制链接]
发表于 2015-9-17 09:28:27 | 显示全部楼层 |阅读模式


                                                                       
iXCache镜像模式部署

iXCache目前有两种工作模式:牵引模式和镜像模式。
牵引模式
        与本公司智能应用网关产品Panabit搭配部署,灵活方便,部署简单易上手,且无需烦恼vlan、PPPOE环境部署困难等问题
镜像模式
        与可做数据镜像的设备搭配部署,且支持PPPOE环境内部署
建议
        使用牵引模式效果要比镜像模式更好,部署更方便。

一、镜像模式


1.1 拓扑图示例:

镜像模式部署图

镜像模式部署图


1.2 对该方案的解析

iXCache镜像模式下,有两个网口:镜像口和数据口。
镜像口
        也即采集数据口,专门接收镜像设备镜像过来的数据;
        建议将上行数据镜像给iXCache镜像口
       
数据口
        功能有二:1. 出网下载资源,补充到iXCache存储池中,故需保证该接口能够正常上网下载资源;
                        2. 向用户输出资源,故需保证该接口与用户相通。
该方案适用于PPPOE环境和非PPPOE环境

1.3 配置iXCache

镜像模式iXCache配置图

镜像模式iXCache配置图


注:
如果iXCache位于PPPOE环境内部,则需开启“PPPOE增强模式”。


1.4 配置镜像

可根据镜像设备厂家提供的镜像指令将上行数据(最好是80端口数据)镜像给iXCache镜像口。


1.5 iXCache在PPPOE环境外的镜像模式部署案例

1.5.1 部署拓扑图

PPPOE环境外用户案例

PPPOE环境外用户案例


1.5.2 部署图说明
1、用户为PPPoE接入,BRAS为华为MA5200,核心交换机为华为S9712,边缘路由器为华为NE40E;
2、华为MA5200上联口接在华为S9712(interface GigabitEthernet1/0/4)上;
3、S9712和NE40E之间的连接为三层路由方式,因此镜像S9712的上联口(interface XGigabitEthernet12/0/0)上行流量;

1.5.3 交换机配置
observe-port 1 interface GigabitEthernet1/0/11[将GE1/0/11口加入镜像分组1]

interface Vlanif6
ip address 172.16.16.1 255.255.255.224[MA5200管理IP的网关]

interface Vlanif50
  ip address 10.232.128.1 255.255.255.224[IXCache管理口网关]

interface GigabitEthernet1/0/4[MA5200管理口]
undo negotiation auto
description linkto_5200f-1(26)_172.16.16.22
port link-type access
port default vlan 6

interface GigabitEthernet1/0/10[IXCache管理口]
description LinkToiXCache_Manage
port link-type access
port default vlan 50
#
interface GigabitEthernet1/0/11[IXCache镜像口]
description Mirror_UPLINK_LinkToiXCache

interface XGigabitEthernet12/0/0
description linkto_SG-A-CR-NE40E-0
port link-type access
port default vlan 1511
port-mirroring to observe-port 1 outbound[镜像上行流量]

1.5.4 iXCache网络配置

PPPOE环境外iXCache配置

PPPOE环境外iXCache配置


1.6 iXCache镜像模式 + ROS + OLT部署案例
1.6.1 部署拓扑图

ros+ixcache+olt

ros+ixcache+olt

1、按照上图拓扑图示连接好各个设备,WAN扩展交换机的20口连接ROS,24口做观察口,镜像20口的入站流量(交换机20口的入站流量就是ROS的WAN口的出站流量,就是我们通常讲的上传流量)至观察口24口。
(Config)#observe-port 1 interface GigabitEthernet 0/0/24(设置观察端口24)
(Config)#interface g0/0/20
(Config-g0/0/20)#port-mirroring to observe-port 1 inbound(镜像入站流量)

华为交换机的镜像配置如有不明白请看下面连接,(记住,我们只需要20口的入站流量)
http://jingyan.baidu.com/article/7f41ecece8a25b593d095cbe.html

2、服务器安装iXCache系统升级到最新版本,设置镜像模式以及镜像口,不用开启pppoe增强,因为镜像过来的数据里面没有PPPOE包
iXCache的配置如下:
图片1.png

3、设置ROS,允许iXCache上网
    设置iXCache网关IP,ROS端口IP
图片2.png
    设置伪装NAT上网
图片3.png
    测试iXCache上网
图片4.png

4、理论上是设置完了,但是很多同学的都只下载不输出是什么回事呢
主要原因有如下:
(1)镜像的不是WAN扩展交换机20口的入站流量,是自己内部pppoe的流量
(2)ROS使用了多线路叠加,NTH负载均衡或者PCC负载均衡
(3)iXCache与内网用户不通路由,可能网段重复导致
解决上面问题:
(1)严格按照上图镜像WAN扩展交换机20口的入站流量给iXCache的镜像口
(2)写两条允许策略并且拉到最上面,内容就是允许用户与缓存互相访问
图片5.png
图片6.png
  3)检查ROS ip-poll跟iXCache的下载口是否重复
图片7.png
图片8.png
发表于 2015-11-1 15:35:59 | 显示全部楼层
镜像口就是交换机端口做一个镜像吗?
发表于 2015-11-27 09:30:03 | 显示全部楼层
wjhlgz 发表于 2015-11-1 15:35
镜像口就是交换机端口做一个镜像吗?

是的是的是的,必须超过十个字
发表于 2016-3-3 17:31:26 | 显示全部楼层
请问ixcache镜像模式通过什么方式登录后台进行管理呢?是数据口的ip地址吗?
发表于 2016-3-3 18:42:21 | 显示全部楼层
oxygen686 发表于 2016-3-3 17:31
请问ixcache镜像模式通过什么方式登录后台进行管理呢?是数据口的ip地址吗?

是的是的是的是的是的(刚好10个字符)哈哈
发表于 2017-2-24 01:07:43 | 显示全部楼层
有个问题啊,我用的ros,上联网线直接走了,ros下面接着olt,这种情况镜像olt到ros的上行方向可以吗?
您需要登录后才可以回帖 登录 | 注册

本版积分规则


QQ|小黑屋|手机版|Archiver|北京派网软件有限公司 ( ICP备案序号:京ICP备14008283号  

GMT+8, 2017-11-20 01:48 , Processed in 0.268554 second(s), 28 queries .

Powered by Discuz! X3.1

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表